Below is collection of Cisco commands that are often used in configuration.
It covers 90% of CCNA commands.
__
Basic commands
enable - Priviliged exec mode
conf t - Enters global configuration
hostname - Renames
router to
exit - Back once
end - Back to #
banner motd * - Editing banner, end with *
enable secret - Set enable
password to
int x - Configure interface x
ip add IP MS - Set IP and MaSk for interface
no sh - Starts interface (w/ sh close int)
clock rate - Clock rate n for serial ports
bandwidth - Set bandwidth n in kilobit
line console x - Configure line x
line vty x - Configue vty x
password x - Password x for line
login - Logs in for password
service password-encryption - Encrypts password
no ip domain-lookup - No ip domain lookup
ip default-gateway - Default gateway (when no routing)
ip default-network - Default network (when there is routing)
ip route 0.0.0.0 0.0.0.0 - Default route address
to 0, from/to (x=ip or int)
ip route -
Static route from/to ip or interface
ip route
- is the value for administrative
distance
logging trap debugging - Shows all console messages
copy run start - Copies running config to startup
erase startup - Erases startup config
delete flash: - Delete from flash
memory
__
Basic sh/debug commands
sh history - Shows history
sh run/start - Shows running/start config
sh int - Shows interfaces
sh arp - Shows arp
sh ip ro - Shows ip routes
sh prot - Shows protocols
sh users - Shows users
sh ip route
sh protocols
sh interface
debug ip rip/eigrp/ospf
__
SSH and user
hostname
ip domain name
crypto generate rsa
line vty 0 4
no transport input
transport input ssh
username privilege
secret - Creates xy user with privelege(0-15)
password
__
DHCP commands
ip dhcp pool x - Makes a dhcp pool with name x and enters
network ip ms - Gives IP and mask for dhcp pool
ip dhcp excluded-add ip ip - Excluded addresses (ex. 192.168.1.7-10)
dns-server ip - DNS server for dhcp
domain-name x - Configures x domain name
default-router ip - The default router address (switch)
lease n - Lease time (n) for dhcp clients
DHCP for VLANs
1. Create vlans (vlan 10) and assign vlan to port
1. Create trunk link
2. Create subint (int fa0/0.10)
3. Set encapsulation dot1q and IP address
4. Make dhcp pool
5. In pool set "default route"
6. Request dhcp
Note --> default route = int ip address
__
ACLs
1-99: standard
100-199: extended
2000-2699: extended
access-list 1 permit - Permits on acl 1
access-list 101 permit IOS
filename on the server
tftpdnld - download
__
Basic commands
enable - Priviliged exec mode
conf t - Enters global configuration
hostname
exit - Back once
end - Back to #
banner motd * - Editing banner, end with *
enable secret
int x - Configure interface x
ip add IP MS - Set IP and MaSk for interface
no sh - Starts interface (w/ sh close int)
clock rate
bandwidth
line console x - Configure line x
line vty x - Configue vty x
password x - Password x for line
login - Logs in for password
service password-encryption - Encrypts password
no ip domain-lookup - No ip domain lookup
ip default-gateway - Default gateway (when no routing)
ip default-network - Default network (when there is routing)
ip route 0.0.0.0 0.0.0.0
ip route
ip route
logging trap debugging - Shows all console messages
copy run start - Copies running config to startup
erase startup - Erases startup config
delete flash:
__
Basic sh/debug commands
sh history - Shows history
sh run/start - Shows running/start config
sh int - Shows interfaces
sh arp - Shows arp
sh ip ro - Shows ip routes
sh prot - Shows protocols
sh users - Shows users
sh ip route
sh protocols
sh interface
debug ip rip/eigrp/ospf
__
SSH and user
hostname
ip domain name
crypto generate rsa
line vty 0 4
no transport input
transport input ssh
username
__
DHCP commands
ip dhcp pool x - Makes a dhcp pool with name x and enters
network ip ms - Gives IP and mask for dhcp pool
ip dhcp excluded-add ip ip - Excluded addresses (ex. 192.168.1.7-10)
dns-server ip - DNS server for dhcp
domain-name x - Configures x domain name
default-router ip - The default router address (switch)
lease n - Lease time (n) for dhcp clients
DHCP for VLANs
1. Create vlans (vlan 10) and assign vlan to port
1. Create trunk link
2. Create subint (int fa0/0.10)
3. Set encapsulation dot1q and IP address
4. Make dhcp pool
5. In pool set "default route"
6. Request dhcp
Note --> default route = int ip address
__
ACLs
1-99: standard
100-199: extended
2000-2699: extended
access-list 1 permit
access-list 101 permit
tftpdnld - download
I like your blog post. Keep on writing this type of great stuff. I'll make sure to follow up on your blog in the future.
ReplyDeleteNAT/PAT|
ISDN Configuration
Hi Sandy, Thanks for liking the blog. Sure we are adding more and more intresting stuff to this blog cutting accross all the network technolgies, vendors and services. KIndly subscribe so that you can always be connected to the blog.
DeleteYou can also visit my other blog - trainingenhancers.blogspot.com where all the articles here cuts accross all the domains not just networking.