Network Enhancers - "Delivering Beyond Boundaries" Headline Animator

Tuesday, December 31, 2013

Storage Interview Questions


SAN


What is storage array?

What is storage virtualization?

What are the main constrains of SCSI in storage networking?

What advantages would using an iSCSI Storage Area Network (SAN) give to your organization over using Direct Attached Storage (DAS) or a Fibre Channel SAN?

What is the smallest unit of information transfer in FC?

What is Multipath I/O?s

What is zoning?

What are the main constrains of SCSI in storage networking?

What are different types of protocols used in transportation and session layers of SAN?

What are the types of disk array used in SAN?

What are the protocols used in physical/datalink and network layer of SAN?

How storage virtualization helps to create SAN?


What is storage virtualization?


What is storage array?

How do you install device drivers for the HBA first time during OS installation?

What are application software available to manage Storage Area Network?

What are minimum components needed to establish Basic Storage Area Network?

What is Network Attached Storage (NAS)?

What is difference between SAN and NAS? How SAN is better than NAS?



Fiberchannel


List the comparison between FC and FCOE?

Explain FC login process?

How many classes of service are available in Fibre Channel?

What are the services provided by Fabric to all the nodes?

What are the layers of Fibre Channel Protocol?

What is the smallest unit of information transfer in FC?

What is Simple name server (SNS)?

How does FC Switch maintain the addresses?

What are the 5 states of Arbitrary Loop in FC?

What is zoning?

What are the layers of Fibre Channel Protocol?

What is the difference between LUN and WWN?

What are the services provided by Fabric to all the nodes?

How many classes of service are available in Fibre Channel?

What is the type of Encoding used in Fibre Channel?

What are different types of protocols used in transportation and session layers of SAN?

What are the protocols used in physical/datalink and network layer of SAN?

which are the FC SAN topologies?

When you will deploy Fibre Channel SAN instead of iSCSI SAN?

What are Link speed currently available for Fibre Channel SAN? What is Future?

FCOE



List the comparison between FC and FCOE?

What are benefits of iSCSI SAN over FCOE SAN?

What are the layers of FCOE Protocol?

What are different types of protocols used in transportation and session layers of SAN?

What are the protocols used in physical/datalink and network layer of SAN?

What are benefits of iSCSI SAN over FCOE SAN?

what are Link Speed available for FCOE SAN?

What is future of FC SAN vs FCOE SAN

What is applications of FCOE?

Compare between FCOE and iSCSI

What is FCOE?

Sunday, August 4, 2013

Cisco Preps Its Next Core Router: The 'CTR'



The next Cisco Systems Inc. is apparently named the "CTR" and is aiming for densities of at least 1Tbit/s per slot, according to a Cisco document obtained by Light Reading.

Plenty of details are left out, such as when the CTR might ship. But the document makes it clear that the platform is meant to be a step beyond the CRS-3 core router:


  • The router would support 1Tbit/s per slot in the form of a card with ten 100Gbit/s ports. Whether this card would be available right away isn't clear.That would still fall short of the 12 100Gbit/s ports per card that Arista announced for its switches, but, depending on when the card arrives, it could be the best density for a core router. As a point of comparison, the Alcatel-Lucent 7950 Extensible Routing System got announced last year with a theoretical per-slot capacity of 1.6Tbit/s (800Gbit/s if you're not double-counting the traffic).
  • It would double as an MPLS label-switched router, to provide the kind of Layer 2 "lean core" (Cisco's phrase) that some carriers are talking about.
  • It would be an ASIC-driven design, as usual. The network processor involved would carry 336 packet-processing cores on-chip and would handle both Ethernet processing and OTN framing.
  • Cisco declined to comment on any of this, but sources close to the company confirmed Thursday that that a new core-routing platform is planned for launch later this year.


Such a system would give Cisco an answer to the Leading-Lights-award-winning AlcaLu 7950, which Cisco initially disparaged as not being a core core router.

Separately, the document appears to confirm plans to produce 10Gbit/s and 40Gbit/s versions of the CPAK interface -- that is, modules with ten 10Gbit/s ports or two 40Gbit/s ports.

CPAK is Cisco's home-grown optical interface module, built with silicon photonics and providing power and density levels compatible with the CFP2 standard.


Monday, July 29, 2013

Huawei working to develop 5G technology


It can provide speed of 10 GBps, which is 100 times faster than the mobile technology used these days

As people across the world get used to the fourth generation (4G) mobile technology, Chinese equipment maker Huawei Technologies has said it is working on the fifth generation (5G), which is likely to be available for use by 2020.

The company said presently 200 people are working on the project and it has earmarked a specified amount for the research and development of the technology. It, however, refused to share details about the amount to be spent for the development of the technology.

Huawei Technologies official Wen Tong said that by 2020, there will be billions of connections and 5G can provide massive connectivity. The technology will enable people to have a fibre network like user experience on a wireless connection.

It can provide speed of 10 GBps, which is 100 times faster than the mobile technology used these days, Tong added.

South Korean giant Samsung has also announced that it has successfully tested 5G technology and it will be ready for commercial roll-out by 2020.

Mobile operators across the world have started moving towards the high-speed long term evolution (LTE) or 4G networks and Huawei provides equipment to 85 such networks.

The company is also undertaking a trial run to test the speed on its 4G technology on high speed MagLev train in Shanghai.

Huawei has deployed an LTE network to support wireless connectivity on the train, which runs between the centre of the Shanghai district to the International Airport. The total length of the track is 31 km and the train achieves a speed of up to 431 km per hour.

The company said on that speed, its 4G technology can provide a download speed of up to 50 MBps.


Sunday, July 28, 2013

The future is 5G


5G wireless networks are expected to emerge in the market between 2020 and 2030

5G or 5th generation mobile technology is a term used to describe the next major phase of mobile telecommunications standards beyond the current 4G standards. 5G is expected to meet the diverse requirements of the future.

There has been a new mobile generation appearing about every tenth year. The 1G system, was introduced in 1981. This was followed by the 2G system which started to roll out in 1992 and the 3G system made its appearance in 2001. 4G systems were standardised in 2012. Thus, mobile communications technologies that are expected to appear beyond 2020 are referred to as 5G.

However, there is as yet no agreed definition of 5G as it is still very much in the concept stage. It needs to be noted that the International Telecommunication Union (ITU), the United Nations agency that defines industry standards, nor standardisation bodies such as 3GPP and WiMAX Forum have established standards for 5G technologies as yet. Thus, for some skeptics, all talk of 5G, even before 4G has properly taken off, is merely a marketing gimmick. Marketers love to appropriate such terms for their advertising campaigns.

Players like Ericsson expect 5G solutions to not consist of a single technology but rather an integrated combination of radio-access technologies. This would include existing mobile-broadband technologies such as HSPA and LTE that will continue to evolve and will provide the backbone of the overall solution beyond 2020. There will also be new complementary technologies. Smart antennas, expanded spectrum and improved coordination between base stations will be some of the new innovations.

Why 5G is required

5G is needed because of the explosive growth in video traffic, the acute shortage of spectrum, the growing need to minimise the energy requirements of web devices and network infrastructure and to cater to the insatiable desire for higher data speed rates.

For the customer, the difference between 4G and 5G technologies will be in higher  speeds, lower battery consumption, better coverage, higher number of supported devices, lower infrastructure costs, higher versatility and scalability or higher reliability of communications.

The METIS project, co-funded by the European Commission, aims at reaching worldwide consensus on the future global mobile and wireless communications system. The overall technical goal is to provide a system concept that supports 1,000 times higher efficiency as compared with current LTE deployments.

The University of Surrey has been given the go-ahead to set up a 5G Innovation Centre backed up by a total of £35m investment from a combination of the UK Research Partnership Investment Fund and a consortium of key mobile operators and infrastructure providers including Huawei, Samsung, Telefonica Europe, Fujitsu Laboratories Europe, Rohde & Schwarz and AIRCOM International.

Though there is no globally agreed 5G standard yet, South Korea is exploring spectrum bands like 13 GHz, 18 Ghz and 27 GHz for 5G technology, which will be capable of transmitting data at speeds in excess of a 1,000 megabits per second (Mbps).

Taiwan, which now lags behind in the development of 4G technologies after having wrongly bet on the now less accepted WiMAX technologies wants to be in the forefront to develop 5G technology.

Major companies in wireless technology are also jockeying for position to influence the next wave of standards beyond 4G LTE. In the Metis project, Huawei is playing the leading role in the Radio Link Technology stream.

South Korea's Samsung Electronics, which has announced that it wants to make available 5G to the public by 2020, said that it had successfully tested ultra-fast fifth generation data transfer using millimeter-wave transceiver technology in May 2013. Semiconductor company Broadcom has unveiled a new combo chip that promises to deliver the fifth generation of broadband wireless connectivity.

Outlook

In order to sustain the continuous growth of wireless business, and to support the industry’s response the ‘Big Data’ challenge, 5G wireless networks are expected to emerge in the market between 2020 and 2030.

Friday, July 5, 2013

Difference between SDN, OpenFlow and OpenStack?


SDN is a broadly defined term focused in on evolving the networking paradigm by leveraging software principles for solving networking challenges such as day to day operations.

OpenFlow is the first practical example of a protocol that enables the separation of control & data plane.

OpenStack is a set of software modules that when used together helps an organization build private & public cloud offerings. OpenStack has compute, storage & networking elements which enable customers an alternative, open source, choice for building their cloud environments. OpenStack can be deployed in traditional network environments, OpenFlow based networks.

OpenStack is independent from SDN or OpenFlow.


Thursday, July 4, 2013

What is Entropy Label?


In any network currently load balancing is achieved by Link Aggregation or Equal Cost Multipath (ECMP) mechanism. ECMP is multiple paths with same cost to reach a particular destination. Any path can be used to reach the destination. 

While ECMP load balancing can be per packet, it may result in Jitter or delay and even Out-of-Order packets to ultimate destination. Current ECMP load balancing is flow specific where it will consider Src/Dst IP address, Transport protocol (UDP or TCP), and Src/Dst Port details from the packet, collectively can be considered as KEYS and input the same to load balancing algorithm to get the egress link. 

With MPLS network, Transit LSR in order to get the KEYS for load balancing algorithm may require to perform deep packet inspection. A new idea is proposed to eliminate the need to have Transit LSR to perform deep packet inspection. The Idea is to have ingress LER pull the KEYS from the native packet, input the same to load balancing algorithm and place the resulting value as label known as ENTROPY LABEL and send across the MPLS network. Any LSR along the path can use the, already hashed value in entropy label for load balancing.

Below are few points to remember about Entropy label,

• Will not be used for forwarding decision and is used only to carry load balancing information.
• Will be generated by Ingress LER
• Must be at the bottom of the label stack with Bottom of Stack set to 1
• Must have TTL value set to “0”

Since Entropy label will now be the bottom most label, application label like VPN label (in case of MPLS VPN) or Tuel label (In case of L2VPN) will not be with BoS=1. Any egress (supporting entropy label feature) when receiving MPLS packet with Application label with BoS=0, understands that there is one more label which is entropy label and will pop the same and send across.

What is Entropy Label Indicator?

In Some applications like MPLS VPN, egress PE will have Application label as the bottom most and so can understand that there is entropy label if the application label is with BoS=0. But there are few applications like CsC VPN, where the egress PE of Carrier provider will pop the application label and will send labeled packet to Carrier customer device. In this case, the application label will always be with BoS=0. So we need other way to identify if there is Entropy label. This is does by Entropy Label Indicator (ELI).


 
On control plane, Egress LER will signal ELI value (label assignment as usual) to remote Ingress LER devices. So when Entropy label is pushed by Ingress, it will push ELI label on top of Entropy label with BoS=0 and TTl=0.


 

How Entropy Label Support and optional Entropy Label Indicator signaled between LER?

With LDP signaling, a new SUB-TLV (Entropy Label SUB-TLV) is used (Type to be decided). It contains 20 bit “VALUE” space which will be zero when ELI is not required and will be non-zero if ELI is required and this value will be used in ELI label.

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |U|F|        Type (TBD)         |           Length (8)          |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |               Value                   |     Must Be Zero      |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

With BGP Signaling, a new Optional, Transitive Path Attribute (Tentatively known as Entropy Label Attribute) will be used in BGP UPDATE while advertising the NLRI.

With RSVP-TE, Entropy Label Attribute TLV will be signaled in LSP_ATTRIBUTES OBJECT in both PATH message and RESV message.



How does it function at DataPlane?


 
1.       Ingress LER on receiving the packet will look into FIB table to identify the egress LER and the associated label details.
2.       Once Egress LER is identified, it will check if Entropy label is supported by egress LER. If it doesn’t support, it simply pushes the label details and send across to intermittent LSR devices.
3.       If Egress LER supports Entropy label and if it doesn’t require ELI, Ingress PE will push where TL is the Tunnel Label is the top label to reach Egress PE, AL is the Application Label and EL is the Entropy label with Entropy value which is calculated by running hashing function on KEYS from native packet; S=0; TTL=0.
4.       If Egress LER supports Entropy label and if it  requires ELI, Ingress PE will push where TL is the Tunnel Label is the top label to reach Egress PE, AL is the Application Label, ELI label is the one signaled by egress PE and EL is the Entropy label with Entropy value which is calculated by running hashing function on KEYS from native packet; S=0; TTL=0
5.       Any Transit LSR will use the value in Entropy Label if load balancing is required.
6.       Egress PE on receiving the MPLS packet will check if Application Label is set as Bottom of Stack. If yes, it will removes the last/bottom label and send across.
7.       If Application is not set as Bottom of stack, Egress PE will check if bottom label is set with S=0 and TTL=0. If yes, it will confirm if the ELI is the value advertised by self.
8.       If Application is not set as Bottom of stack, Egress PE will check if bottom label is set with S=1 and TTL=0, it understood that this is Entropy label and will remove before sending to CE device.

Thursday, June 6, 2013

New Cloud Managed Services and Catalyst Switch



Since our acquisition of Meraki in late 2012, you have heard us talking about the midmarket and new opportunities for channel partners and customers. I’m pleased to say that today, at the Cisco Partner Summit in Boston, we have some exciting updates for you. Specifically, we’ll focus on our Made for Midmarket portfolio which includes a range of new product offerings, services and solutions designed for midsize customers.

As part of Cisco’s newly formed Cloud Networking Group, we are unveiling our complete cloud managed networking portfolio specifically focused for midmarket deployments, consisting of security appliances, switches and wireless LANs.
Get Your Heads in the Cloud – Services and Revenue Opportunities

New for partners today we are introducing the Cisco Meraki Managed Services Dashboard – bringing together a number of features for Managed Service Providers (MSP) to offer cloud-managed networking as a service to their customers. This MSP dashboard features specific tools, analytics and monitoring capabilities and is built to allow our service providers to manage end-customer networks easily from a central location while still maintaining separation and security of each customer network.

Key Highlights of the Managed Services Dashboard

  • MSP Portal – Service providers can easily monitor the health of end-customer networks from a centralized location.
  • Manage your Brand: MSPs can customize the logo on the dashboard to promote their own brand with end-customers. Cisco will work directly with the MSP to customize the content.
  • Support Ticketing: Easy for MSPs to create, monitor and respond to support cases with Cisco staff.
  • Remote Live Tools: A complete set of tools that make remote monitoring of the network significantly easier – a perfect fit for Helpdesk or Network Operations Center (NOC) staff.
  • Partner Benefits: Using the new MSP dashboard, partners can increase profits through managed services, enable existing MSPs to profitably grow their midmarket offering and allow traditional VARs to quickly introduce managed service offerings.
Summary-graphic_v1

It doesn’t end here… also new from Cisco this week is the Catalyst 2960-X series of stackable gigabit Ethernet access switches.

New Catalyst 2960-X Switches
The announcement of the Catalyst 2960-X switches provides our customers with yet another opportunity to cost-effectively address their growing business needs with intelligent services. The Catalyst 2960-X is a perfect fit for midmarket customers who are dealing with challenges associated with BYOD scalability and security – many of the same needs as a big business, but with smaller IT staffs and budgets to meet them.

The new Cisco Catalyst 2K switches doubles the scale of the previous generation of Cat2K switches, while adding application visibility, routing options, and redundant power supply options to provide customers maximum investment protection.

“Green” Energy-Saving Benefits

The Cisco Catalyst 2960-X was designed to reduce the total cost of ownership over comparative industry switches with energy-saving features that can reduce power consumption by up to 80%.

How does this energy-saving performance compare with the rest of the industry? For context, IDC reported roughly 230 million comparable switch ports were sold in 2012[1]. Not that we’re being greedy – but if these were all Catalyst 2960-X units, that would mean roughly 14.4 Billion kWh of energy saved.

What could you do with that energy?
  • Shut down the Hoover Dam for 3.4 years
  • Power all households in San Francisco for 3.3 years
  • Make 76 round trips to Mars in a Toyota Prius, 45,000 round trips to the Moon, or 870,000 trips around the Earth
  • Reduce CO2 emissions by 7.5 billion pounds (3.4 billion kg), the equivalent of planting 193 million trees, the same as every household in the United States planting 1.7 trees

The Cisco Catalyst 2960-X switches will continue to make the Catalyst 2K family the world’s most widely-deployed access switch by addressing business challenges of today and helping customers prepare for the future.

This is just the beginning. Cisco will continue to invest and build out our midmarket overall portfolio of solutions and technology across all areas of our business, for partners to get up and running quickly. From the datacenter, with the Virtualized Foundation Smart Solution, to Collaboration, and beyond – we have lots more in store for partners.

It’s clear that Cisco has its finger on the midmarket pulse. We estimate a $25B technology opportunity by FY16 and approximately $5B will be for networking equipment in our core wireless and cloud networking franchise. We have the broad resources and pedigree to lead in this market. We are excited to grow in this market with our customers and partners, today and tomorrow. For more information on the complete midmarket strategy, which includes marketing and channel support, in addition to the portfolio, check out today’s post from Andrew Sage, Vice President of Worldwide Partners Sales,
 

Monday, May 27, 2013

Differences between Rapid STP (802.1w) and the legacy STP(802.1d)


The following table outlines the main differences between Rapid STP (802.1w) and the legacy STP(802.1d):

STP (802.1d)
Rapid STP (802.1w)
In stable topology only the root sends BPDU and relayed by others.In stable topology all
bridges generate BPDU every Hello (2 sec) : used as “keepalives” mechanism.
Port states
DisabledBlockingListeningLearningForwardingDiscarding (replaces disabled, blocking and listening)
Learning
Forwarding
To avoid flapping, it takes 3 seconds for a port to migrate from one protocol to another (STP / RSTP) in a mixed segment.
Port roles
Root (Forwarding)
Designated
(Forwarding)
Non-Designated
(Blocking)
Root (Forwarding)
Designated
(Forwarding)
Alternate
(Discarding)Backup (Discarding)
Additional configuration to make an end node port a port fast (in case a BPDU is received).- An edge port (end node port) is an integrated Link type which depends on the duplex : Point-to-point for full duplex & shared for half duplex).
Topology changes and convergence
Use timers for convergence (advertised by the root):
Hello
(2 sec)
Max Age
(20 sec = 10 missed hellos)
Forward delay timer (15 sec)
- Introduce proposal and agreement process for synchronization (< 1 sec).- Hello, Max Age and Forward delay timer used only for backward compatibility with standard STP
Only RSTP port receiving STP (802.1d) messages will behaves as standard STP.
Slow transition (50sec):
Blocking (20s) =>Listening (15s) =>Learning (15s) =>Forwarding
Faster transition on point-to-point and edge ports only:Less states – No learning state, doesn’t wait to be informed by others, instead, actively looks for possible failure by RLQ (Request Link Query) a feedback mechanism.
Use only 2 bits from the flag octet:Bit 7 : Topology Change Acknowledgment.Bit 0 : Topology ChangeUse other 6 bits of the flag octet (BPDU type 2/version 2):
Bit 1 : ProposalBit 2, 3 : Port roleBit 4 : LearningBit 5 : ForwardingBit 6 : AgreementBit 0, 7 : TCA & TCN for backward compatibility
The bridge that discover a change in the network inform the root, that in turns informs all others by sending BPDU with TCA bit set and instruct them to clear their DB entries after “short timer” (~Forward delay) expire.TC is flooded through the network, every bridge generate TC (Topology change) and inform its neighbors when it is aware of a topology change and immediately delete old DB entries.
If a non-root bridge doesn’t receive Hello for 10*Hello (advertised from the root), start claiming the root role by generating its own Hello.Wait for 3*Hello on a root port (advertised from the root) before deciding to act.
Wait until TC reach the root + short timer (~Forward delay) expires, then flash all root DB entriesDelete immediately local DB except MAC of the port receiving the topology changes (proposal)

 

Friday, May 24, 2013

ICMP Ping Request World Map & Hilbert map



World map showing the 460 Million IP addresses that responded to ICMP ping requests or port scans from June and October 2012. World map of 24 hour relative average utilization of IPv4 addresses observed using ICMP ping requests.



Hilbert Map

Hilbert map of 24 hour relative average utilization of IPv4 addresses observed using ICMP ping requests.





 

Saturday, May 11, 2013

Contrail: The Juniper SDN controller for virtual overlay network


Juniper Networks will launch a portfolio of software-defined networking products later this year under the brand name JunosV Contrail. The first Juniper SDN product -- available in the third quarter -- will be the Contrail Controller, which will initially provide centralized control for a virtual overlay network.

The Juniper SDN controller is based on technology Juniper acquired last year when it bought startup Contrail Systems. Today, JunosV Contrail Controller is an overlay network solution comparable to VMware NSX, Midokura MidoNet and Nuage Networks. The controller interacts with virtual switches on hypervisor hosts using Extensible Messaging and Presence Protocol (XMPP) as its control plane protocol. Contrail Controller also uses Border Gateway Protocol (BGP) for control plane scaling across LANs and WANs.

"XMPP offers lower overhead and higher performance," said Joe Skorupa, vice president and distinguished analyst at Stamford, Conn.-based Gartner Inc. "And they use BGP for federation across controllers."

The Contrail Controller doesn't support OpenFlow or any other protocols for direct control of network hardware, but Juniper didn't rule out future support. For now, Juniper is focusing on delivering a virtual overlay network.

"Most of the infrastructure that is out there today either doesn't have OpenFlow capabilities on it or will require some upgrade to get it, which means rip and replace," said Brad Brooks, Juniper vice president of marketing and strategy. "The protocols we're using with Contrail mean you can overlay software right on top of existing infrastructure and get benefits right away. It's not to say we won't support OpenFlow [in our controller]. If it becomes a de facto standard for how to communicate with the underlying physical network, then we can put that in support for the controller. But we're really looking at and focusing on standard protocols that already exist in physical networks today."

Juniper SDN eyes carriers and enterprises with scale, open APIs


Juniper Networks Inc. is angling JunosV Contrail at both carriers and enterprises, said Jennifer Lin, senior director of product management for Sunnyvale, Calif.-based Juniper. Both are looking for "ways to drive better operational efficiency and ensure that the network is exposed as a service or set of services, and not just a siloed part of the infrastructure," she said.

To that end, Juniper is exposing a RESTful application programming interface (API), instantiating its own OpenStack Quantum plug-in, and announcing several partnerships geared toward integrating its SDN technology with leading cloud orchestration systems. It's partnering with Citrix on CloudStack integration and with Cloudscaling and Mirantis on OpenStack integration.

Contrail's scale-out control plane based on BGP will appeal to carriers, enterprises and cloud providers looking to federate controllers across the WAN.

"We're focused on how to get a scale-out control plane. … In this case, we're extending mature protocols like BGP, which run today's Internet, and linking together autonomous systems across IP networks," Lin said.

Juniper SDN will integrate overlay and underlay for diagnostics and analytics

Like other vendors who are enabling an SDN-like virtual overlay network, Juniper requires basic Layer 3 connectivity on the underlying physical network. Juniper hopes to differentiate itself from VMware and others by connecting the physical and virtual networks together.

"One difference between Juniper and VMware is that Juniper will link management of virtual and physical to enable debugging problems," Skorupa said. "Otherwise, figuring out if the [network] problem is in the overlay or the physical IP network is extremely difficult at best."

Juniper is working on bridging protocols like BGP and MPLS into its overlay network so JunosV Contrail can interact with Juniper's switches and routers to extract diagnostics and analytics from the physical network and combine it with the software overlay, Lin said. "We're able to correlate if something goes wrong in your pod," she said. "You have both the diagnostics of the virtual infrastructure as well as the physical underlay."

Integrating physical and overlay networks will be essential, according to Bob Laliberte, senior analyst with Milford, Mass.-based Enterprise Strategy Group.

"Just like you can't keep on provisioning virtual machines in physical servers without an understanding of what is going on (memory and CPU usage, etc.), these overlay networks need to understand what is going on in the physical infrastructure or underlay," he said.
 

Friday, May 10, 2013

After Taking Aim At The Server Industry, Facebook Targets Cisco


Facebook has made serious progress in its plans to revolutionize the $55 billion server industry and now wants to do the same for the network industry.

The two-year-old Facebook-led consortium called the Open Compute Project has announced plans to create an "open source" network switch.

This could disrupt the $22-billion-a-year Ethernet switch market that mostly belongs to Cisco. Cisco owns over 60% of it, according to IDC.

Najam Ahmad, who runs the network engineering team at Facebook, will lead this new OCP project.

A switch is a piece of hardware that connects different parts of a network and is a central piece of equipment for every enterprise network. OCP plans to make a new kind of switch designed from the get-go for "software-defined networking" (SDN) technology.

SDN is a new way to build networks. Instead of buying expensive hardware routers and switches with a lot of fancy features from companies like Cisco or Juniper, those fancy features are put into software. Companies can then use simpler, cheaper network hardware, and less of it.

A bunch of vendors have already signed on to support the new OCP switch. These include Big Switch Networks, Broadcom, Cumulus Networks, Intel, Netronome, and VMware.

The project also has support from two organizations working on the open source SDN software: the Open Networking
Foundation and the Linux foundation project known as OpenDaylight. Cisco is part of the OpenDaylight project.
The overall goal of the Open Compute Project is to build faster, cheaper hardware for big data centers. Its hardware designs are free for anyone to use and modify.

Eventually, OCP wants to completely change how all enterprise hardware is built the same way that Linux and open source software changed the way software is created.

 

Tuesday, May 7, 2013

Understanding Mobile Router/Mobile Network


What does mobile IP do? It allows a mobile router to keep the same IP address while traveling from one network to another and provides IP connectivity to the IP hosts connecting through the mobile router. The hosts behind the mobile router are unaware of this mobility.

Mobile IP has three components:

1. Home agent (HA) - An HA is a router on the home network that maintains an association between the home IP address of the MR and the current care-of address of the MR on the foreign network. HA redirects packets by tunneling them to the MR while it is away from home (in the foreign network).

2. Foreign agent (FA) - An FA is a router on a foreign network that provides a care-of address to the MR. It also detunnels and delivers packets to the MR that were tunneled by the HA.

3. Mobile router (MR) - A mobile router, moves from one network or subnet to another, "hides" the IP roaming from the IP hosts connecting through this mobile router so that the local hosts appear to be directly attached to the home network.

Let's go through a quick example:


 

The HA R1 is advertising (“redistribute mobile”) reachability to the mobile network 140.80.1.0/24 (on the MR R3) to the internet, thereby attracting packets that are destined for this subnet. MR R3 will keep the same IP address 150.1.1.1 while roaming between its home network 150.1.1.0/24 and foreign networks 200.2.2.0/24, 200.6.6.0/24. So When MR R3 is in foreign network 200.2.2.0/24, it will acquire a care-of address 2.2.2.2 from the FA R2. After receiving the care-of address, the MR R3 will register this address with its HA R1. The HA R1 will create a mobility binding table that maps the home IP address 150.1.1.1 of the MR R3 to the current care-of address 2.2.2.2 of the MR R3.

Now when any device on the Internet, called a corresponding node (CN), sends a packet to the mobile network (more specifically to 140.80.1.1), the packet is routed to the HA R1. Then the HA R1 will double tunnel it (outer tunnel to FA R2 care-of address 2.2.2.2 and inner tunnel to MR R3 itself). The FA R2 removes the outer tunnel header and delivers the inner tunneled packet to the connected MR R3. MR R3 performs another decapsulation to deliver the packet to the destination node 140.80.1.1 on the mobile network.

However, packets sent from the mobile network 140.80.1.0/24 are routed directly to the CN unless a reverse tunnel is configured.

Let's check the configuration on those routers for IP mobility:
Rack1R1 (HA)
!
interface Loopback0
 description HA address
 ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 description home network
 ip address 150.1.1.254 255.255.255.0
!
interface FastEthernet0/1
 description connected to internet
 ip address 180.1.17.1 255.255.255.0
!
! Enables Mobile IP
router mobile
!
router ospf 1
! Redistributes the virtual network into the routing protocol
 redistribute mobile subnets
!
! Enables home agent service
ip mobile home-agent address 1.1.1.1
! Defines mobile router's home network as virtual network
ip mobile virtual-network 150.1.1.0 255.255.255.0
! Specifies mobile router on the virtual network
ip mobile host 150.1.1.1 virtual-network 150.1.1.0 255.255.255.0
! Specifies all the networks behind mobile router
ip mobile mobile-networks 150.1.1.1
 description network behind the mobile router
 network 140.80.1.0 255.255.255.0
! Enables security association between HA and MR
ip mobile secure host 150.1.1.1 spi 100 key ascii CISCO algorithm md5 mode prefix-suffix

Rack1R2 (FA)
!
interface Loopback0
 description care-of-address
 ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
 description foreign network
 ip address 200.2.2.254 255.255.255.0
! Enables foreign agent service on an interface
 ip mobile foreign-service
 ip mobile registration-lifetime 60
! Enables IRDP
 ip irdp
 ip irdp maxadvertinterval 4
 ip irdp minadvertinterval 3
!
interface FastEthernet0/1
 description connected to internet
 ip address 180.1.27.2 255.255.255.0
!
! Enables Mobile IP
router mobile
!
! Enables foreign agent service globally with the care-of-address
ip mobile foreign-agent care-of Loopback0

Rack1R3 (MR)
!
interface Loopback0
 description mobile network
 ip address 140.80.1.1 255.255.255.0
!
interface Ethernet0/0
 description the roaming interface
 ip address 150.1.1.1 255.255.255.0
! Enables roaming on an interface
 ip mobile router-service roam
!
! Enables Mobile IP
router mobile
!
! Enables security association between MR and HA
ip mobile secure home-agent 1.1.1.1 spi 100 key ascii CISCO algorithm md5 mode prefix-suffix
! Enables the mobile router 
ip mobile router
 address 150.1.1.1 255.255.255.0
 home-agent 1.1.1.1

We will do some testing and verification when mobile router R3 is in the foreign network 200.2.2.0/24 on R2.
Rack1R1#show ip route | inc ^M
M       140.80.1.0 [3/1] via 0.0.0.0, 00:15:18, Tunnel0
M       150.1.1.1/32 [3/1] via 2.2.2.2, 00:15:18, Tunnel1
Rack1R1#show ip mobile binding 
Mobility Binding List:
Total 1
150.1.1.1: 
    Care-of Addr 2.2.2.2, Src Addr 2.2.2.2
    Lifetime granted 00:01:00 (60), remaining 00:00:55
    Flags sbdmg-t-, Identification CE22A5D5.F4C99770
    Tunnel1 src 1.1.1.1 dest 2.2.2.2 reverse-allowed
    MR Tunnel0 src 1.1.1.1 dest 150.1.1.1 reverse-allowed
    Routing Options - 
    Mobile Networks: 140.80.1.0/255.255.255.0 (S)
Rack1R1#sh ip mobile tunnel
Mobile Tunnels:
Total mobile ip tunnels 0
Tunnel0:
    src 1.1.1.1, dest 2.2.2.2
    encap IP/IP, mode reverse-allowed, tunnel-users 1
    Input ACL users 0, Output ACL users 0
    IP MTU 1480 bytes
    Path MTU Discovery, mtu: 0, ager: 10 mins, expires: never
    outbound interface FastEthernet0/1
    HA created, fast switching enabled, ICMP unreachable enabled
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 drops
    20 packets output, 23125 bytes
Tunnel1:
    src 1.1.1.1, dest 150.1.1.1
    encap IP/IP, mode reverse-allowed, tunnel-users 1
    Input ACL users 0, Output ACL users 0
    IP MTU 1460 bytes
    Path MTU Discovery, mtu: 0, ager: 10 mins, expires: never
    outbound interface Tunnel0
    HA created, fast switching enabled, ICMP unreachable enabled
Mobile Tunnels:
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 drops
    20 packets output, 22725 bytes
Rack1R1#show ip mobile mobile-networks
Mobile Networks:
MR 150.1.1.1 [network behind the mobile router]:
    Configured: 140.80.1.0/255.255.255.0
    Registered:
Rack1R2#sh ip route | be Gateway
Gateway of last resort is not set
     1.0.0.0/24 is subnetted, 1 subnets
O       1.1.1.0 [110/3] via 180.1.27.7, 15:28:38, FastEthernet0/1
O    222.22.2.0/24 [110/2] via 180.1.27.7, 15:28:48, FastEthernet0/1
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
O    200.6.6.0/24 [110/3] via 180.1.27.7, 15:28:48, FastEthernet0/1
     140.80.0.0/24 is subnetted, 1 subnets
O E2    140.80.1.0 [110/20] via 180.1.27.7, 00:29:32, FastEthernet0/1
     6.0.0.0/24 is subnetted, 1 subnets
O       6.6.6.0 [110/3] via 180.1.27.7, 15:28:48, FastEthernet0/1
C    200.2.2.0/24 is directly connected, FastEthernet0/0
     180.1.0.0/24 is subnetted, 3 subnets
O       180.1.17.0 [110/2] via 180.1.27.7, 15:28:48, FastEthernet0/1
C       180.1.27.0 is directly connected, FastEthernet0/1
O       180.1.67.0 [110/2] via 180.1.27.7, 15:28:48, FastEthernet0/1
     150.1.0.0/16 is variably subnetted, 2 subnets, 2 masks
O       150.1.1.0/24 [110/3] via 180.1.27.7, 00:29:32, FastEthernet0/1
M       150.1.1.1/32 [3/1] via 150.1.1.1, 00:30:09, FastEthernet0/0
                     [3/1] via 150.1.1.1, 00:00:08, FastEthernet0/0
Rack1R2#sh ip mobile tunnel
Mobile Tunnels:
Total mobile ip tunnels 0
Tunnel0:
    src 2.2.2.2, dest 1.1.1.1
    encap IP/IP, mode reverse-allowed, tunnel-users 1
    Input ACL users 0, Output ACL users 0
    IP MTU 1480 bytes
    Path MTU Discovery, mtu: 0, ager: 10 mins, expires: never
    outbound interface FastEthernet0/1
    FA created, fast switching enabled, ICMP unreachable enabled
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    20 packets input, 23125 bytes, 0 drops
    0 packets output, 0 bytes
Rack1R2#show ip mobile globals
IP Mobility global information:
Home Agent is not enabled
Foreign Agent
    Pending registrations expire after 7 secs
    Care-of addresses advertised
    Mobile network route injection disabled
        Loopback0 (2.2.2.2) - up
1 interface providing service
Encapsulations supported: IPIP and GRE
Tunnel fast switching enabled, cef switching enabled
Tunnel path MTU discovery aged out after 10 min
NAT UDP Tunneling support enabled
UDP Tunnel Keepalive 110
Forced UDP Tunneling disabled
Rack1R2#show ip mobile visitor 
Mobile Visitor List:
Total 1
150.1.1.1:
    Interface FastEthernet0/0, MAC addr 0006.533a.2581
    IP src 150.1.1.1, dest 200.2.2.254, UDP src port 434
    HA addr 1.1.1.1, Identification CE22AC48.A0CA5400
    Lifetime 00:01:00 (60) Remaining 00:00:32
    Tunnel0 src 2.2.2.2, dest 1.1.1.1, reverse-allowed
    Routing Options - 
Rack1R2#show ip mobile interface
IP Mobility interface information:
Interface FastEthernet0/0:
    IRDP (includes agent advertisement) enabled
    Prefix Length not advertised
    Lifetime is 60 seconds
    Foreign Agent service provided
    Foreign Agent challenge disabled
    Reverse tunnel not supported
    No registration required
    Not busy
    Home Agent access list:
    Registration revocation disabled
         Current number of visitors: 1
Rack1R3#sh ip route | be Gateway
Gateway of last resort is 200.2.2.254 to network 0.0.0.0
     1.0.0.0/32 is subnetted, 1 subnets
M       1.1.1.1 [3/1] via 200.2.2.254, 00:50:11, Ethernet0/0
     140.80.0.0/24 is subnetted, 1 subnets
C       140.80.1.0 is directly connected, Loopback0
     200.2.2.0/32 is subnetted, 1 subnets
M       200.2.2.254 [3/1] via 200.2.2.254, 00:50:11, Ethernet0/0
     150.1.0.0/24 is subnetted, 1 subnets
C       150.1.1.0 is directly connected, Ethernet0/0
M*   0.0.0.0/0 [3/1] via 200.2.2.254, 00:50:11, Ethernet0/0
Rack1R3#sh ip mobile tunnel
Mobile Tunnels:
Total mobile ip tunnels 1
Tunnel0:
    src 150.1.1.1, dest 1.1.1.1
    encap IP/IP, mode reverse-allowed, tunnel-users 1
    IP MTU 1480 bytes
    Path MTU Discovery, mtu: 0, ager: 10 mins, expires: never
    outbound interface Ethernet0/0
    MR created, fast switching enabled, ICMP unreachable enabled
    5 minute input rate 0 bits/sec, 0 packets/sec
    5 minute output rate 0 bits/sec, 0 packets/sec
    20 packets input, 22725 bytes, 0 drops
    0 packets output, 0 bytes
Rack1R3#show ip mobile router
Mobile Router
    Enabled 08/03/09 21:04:42
    Last redundancy state transition NEVER
Configuration:
    Home Address 150.1.1.1 Mask 255.255.255.0
    Home Agent 1.1.1.1 Priority 100 (best) (current)
    Registration lifetime 65534 sec
    Retransmit Init 1000, Max 5000 msec, Limit 3
    Extend Expire 120, Retry 3, Interval 10
Monitor:
    Status -Registered-
    Active foreign agent 200.2.2.254, Care-of 2.2.2.2
    On interface Ethernet0/0
    Tunnel0 mode IP/IP
Rack1R6#ping 140.80.1.1 size 1460 df-bit 
Type escape sequence to abort.
Sending 5, 1460-byte ICMP Echos to 140.80.1.1, timeout is 2 seconds:
Packet sent with the DF bit set
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms
Rack1R6#ping 140.80.1.1 size 1461 df-bit 
Type escape sequence to abort.
Sending 5, 1461-byte ICMP Echos to 140.80.1.1, timeout is 2 seconds:
Packet sent with the DF bit set
M.M.M
Success rate is 0 percent (0/5)
Rack1R6#trace 140.80.1.1                 
Type escape sequence to abort.
Tracing the route to 140.80.1.1
  1 180.1.67.7 4 msec 4 msec 0 msec
  2 180.1.17.1 4 msec 0 msec 0 msec
  3 150.1.1.1 4 msec *  0 msec
 

Sunday, May 5, 2013

Four Steps for Optimising Customer Service Operations

 
Customers want efficient, effortless service from the touchpoint and communication channel of their choice. They want to receive accurate, relevant, and complete answers to their questions upon first contact with a company.
 
Forrester data backs this up: Sixty-six percent of customers agree that valuing their time is the most important thing a company can do to provide good service. Forty-five percent of US online adults will abandon their online purchase if they can’t find a quick answer to their question. Why is it so important to deliver on customer expectations? Customer satisfaction correlates to customer loyalty, and loyalty has economic benefits.
 
Forrester calculates that a 10-percentage-point improvement in a company’s customer experience score can translate into more than $1 billion in revenue. Conversely, poor customer experiences are costly: Our data shows that 75% of consumers move to another channel when online service fails, which can incur a cost of many millions of dollars.
 
We also know that it is difficult to deliver customer service in line with customer expectations. Our customer service technology ecosystem is increasingly complex. Social technologies have disrupted traditional communications, and smartphones and tablets have made the delivery of consistent experiences across touchpoints more challenging. And the number of vendor mergers and acquisitions has complicated vendor selection.
 
So how do you do better? Forrester’s customer service playbook details a four-step prescription that can help you out:
 
Discover what matters for customer service. Understand customer-facing, agent-facing, and technology trends that are shaping the future of customer service-trends like changes in communication channel usage by demographic, mobility solutions for customer service, the value of tighter coupling of knowledge management to case management, BPM adoption, the rising importance of outsourcing, cloud-based technologies, and the evolving technology landscape.
 
Plan for improvements. Assess your current operations against best practices to understand your strengths and pinpoint areas of opportunity. This will help you build a concrete plan for improvements and lay out a technology adoption road map. It will help you answer questions such as
“Do I first fix my IVR navigation, launch web self-service, or update my case management solution?”
 
Act on your findings. With your planning in place, it’s time to choose whether to outsource customer service operations and/or technology, buy it from a vendor, or, in unique cases, build it yourself. This decision is very important, as the vendor landscape is broad, mature, and rife with mergers and acquisitions. Partnering with the right technology provider can make or break your operations.
 
Optimise. Customer service is no longer viewed as just a cost centre. Key success metrics have historically focused on productivity, efficiency, and regulatory compliance instead of customer satisfaction. However, forward-thinking organisations are gradually adopting a Balanced Scorecard of metrics that include not only cost and compliance, but also customer satisfaction, which is more suited to drive the right agent behaviour and deliver outcomes better aligned to customer expectations.
 

Wednesday, May 1, 2013

Customer Experience Is Greatest Untapped Source of Profits

Courtesy - Computer world


Analyst firm Forrester claims that customer experience is the greatest untapped source of profits in business today, and that projects commissioned to target this are putting pressure on technology departments.

Harley Manning, co-author of “Outside In: The Power of Putting your Customers at the Centre of your Business”, told Computerworld UK that companies need to rethink how they approach customer experience.

“If you look at customer experience from the perspective of what it can do to decrease your costs, what it can do to increase your revenue, and then look at the return on investment from doing those kind of projects, then the discussion of customer experience happens on a very different level and you realise that is probably the greatest untapped source of profits in business today,” said Manning.

“If you set out to be the best in the world at marketing you would struggle because it is a mature discipline and well understood. However, if you said you are going to focus on providing a better customer experience than your competitors, suddenly you are competing in a different arena.”

Manning said that it is hard to assess your systems internally to understand what impact they are having on the customer’s experience, and as a result the technology department should take an ‘outwards-in’ perspective, whereby it assesses every point at which the customer interacts with the business.

“Take each of those touches that the customer has with your company. Perhaps in a retail location, over the phone, on a website, on a mobile app—looking at whether the underlying people, processes, policies and technologies that contributed to the experience that the customer had at each of those points makes you quickly realise that you have an opportunity to do very specific things with technology to improve that experience,” he said.

Bill Band, principal analyst for Application Development & Delivery at Forrester, agreed with Manning and said that companies are beginning to waken up to the benefits of making customer experience a priority, which is placing pressure on IT departments.

“Improving customer experience is putting new demands on technology departments. In particular, one thing that I have noticed is that the projects that get backing tend to cluster around digital interactions with customers because in this day and age a lot of these revolve around mobile or web.

“As a result, a lot more technology-heavy projects are being commissioned around these customer experiences,” said Band.

“Also, the role of technology employees inside these organisations is changing as companies start to focus more on the customer experience. Technology employees have to become more strategic,” he added.

“There is more of a spotlight being placed on the IT organisation to help execute business strategy. So it’s no longer about maintenance and support, these people are now important strategic assets. A lot of them are moving out of pure IT roles into business technology roles and are moving closer to marketing/sales business units.”

The book will be published on 28 August and includes more than 80 case studies from across 15 industries in 16 countries, including examples from Boeing, E.ON Energy, FedEx, T-Mobile and Virgin Media.
 

Tuesday, April 30, 2013

Things to Remember in OSPF


DR and BDR

DR - Designated Router and BDR backup designated Router are Routers on a Broadcast segment. For example Ethernet a DR and optionally an BDR is chosen. The election is based on
  • The highest priority on the interface
    • Default priority is 1. Can be set in the range 0 - 255
    • If priority is set to 0 the router can not be a DR
    • The priority is set on a per-link basis.
  • The highest RID - Router ID
interface fastethernet 0/0
 ip ospf priority 255

RID: Router ID

The RID is the IP address which the Router is known as.
  1. Set manually
  2. Highest Loopback IP address
  3. Highest IP address if no Loopbacks defined
interface Loopback 0
 ip address 10.10.10.1
!
interface Loopback 1
 ip address 192.168.10.1
!
router ospf 1
  router-id 10.10.10.1

Stub Areas

OSPF RFC's describe Stub and Not-So-Stubby-Area. Totally Stub Area is a Cisco proprietary standard.

What is Stub Areas

Stub Areas are part of a network which don't need to have a copy of the total Link-State database. It reduces the memory requirements and CPU overhead of the router. Often stub areas only have a default gateway.

Stub Area

  • Stub Areas blocks Type 5 LSA's. (External Routes)
    • Routing to the outside world is based on a default route.
    • A Stub Area will accept Summary Routes from other Areas.

Totally Stub Area

  • totally Stub Areas blocks Type 3,4 and 5 LSA's. Only a default gateway.
    • Has a default route out of the Area,

NSSA: Not So Stubby Area

  • A NSSA imports a limited number of External Routes. The number of Routes is limited to those Routes required to provide connectivity between Areas.

Example

Example

Stub Area example


Example

Totally Stub Area example


Example

NSSA: Not So Stubby Areas


Example

Example

Example

Example

Virtual links


Example

Example

Example

Single Area configuration

Example 1


Example network 1



hostname R1
!
interface fastethernet 0/0
  ip address 192.168.0.1 255.255.255.0
!
interface fastethernet 0/1
  ip address 10.0.1.1 255.255.255.0
!
router ospf 88
  network 192.168.0.0 0.0.0.255 area 0
  network 10.0.1.0 0.0.0.255 area 0
hostname R2
!
interface fastethernet 0/0
  ip address 192.168.0.2 255.255.255.0
!
interface fastethernet 0/1
  ip address 10.0.2.1 255.255.255.0
!
router ospf 77
  network 192.168.0.0 0.0.0.255 area 0
  network 10.0.2.0 0.0.0.255 area 0
hostname R3
!
interface fastethernet 0/0
  ip address 192.168.0.3 255.255.255.0
!
interface fastethernet 0/1
  ip address 10.0.3.1 255.255.255.0
!
interface serial 0/0
  ip address 172.16.0.1 255.255.255.252
!
router ospf 66
  network 192.168.0.0 0.0.0.255 area 0
  network 10.0.3.0 0.0.0.255 area 0
  network 172.16.0.0 0.0.0.3 area 0
hostname R4
!
interface fastethernet 0/1
  ip address 10.0.4.1 255.255.255.0
!
interface serial 0/0
  ip address 172.16.0.2 255.255.255.252
router ospf 66
  network 172.16.0.0 0.0.0.3 area 0
  network 10.0.4.0 0.0.0.255 area 0

Default administrative Distance

 

Cisco implementation


Default Administrative Distance (metric)
Route SourceDistance
Connected Interface0
Static Route out an Interface0
Static Route to a next hop1
EIGRP summary route5
External BGP20
Internal EIGRP90
IGRP100
OSPF110
IS-IS115
RIP (Version 1 og 2)120
EGP140
ODR (On Denmand Routing)160
External EIGRP170
Internal BGP200
Ukendt source255

 

LSA Types

 

LSA Types
Type ABR Sent to Meaning
1 O 224.0.0.5 Router Link: Indeholder alle Routerens Links. Floodes til Area
2 O 224.0.0.6 Network Link: Floodes fra DR til Area. Indeholder alle Naboer på MA-medie
3 O IA Summary Link: Sendes fra Area til Area gennem ABR. Indeholder IA Summaries.
4 O IA ASBR summary Link: Sendes fra ASBR’s. Indeholder externe router.
5 O E1/2 Externe Router fra ASBR. E1 intern + extern cost. E2 kun extern cost.
7 O E1/2 Externe Routes fra ASBR i NSSA
8 OSPF and BGP internetworking
9,10,11 Opaque LSA used by Cisco for MPLS

 

The following are descriptions of each type of LSA.

 

Type 1


Every router generates router link advertisements for each area to which it belongs. A type 1 LSA describes the collective states of the directly connected links (interfaces) of the router. These LSAs are flooded only within the area in which they are originated.

 

  Type 2


A type 2 LSA is generated for every transit broadcast and NBMA network within an area. A transit network has at least two directly attached OSPF routers. Ethernet is an example of a transit network.
The DR of the network is responsible for advertising the network LSA. A type 2 network LSA lists each of the attached routers that make up the transit network, including the DR itself, as well as the subnet mask used on the link. The type 2 LSA then floods to all routers within the transit network area. Type 2 LSAs never cross an area boundary. The link-state ID for a network LSA is the IP interface address of the DR that advertises it.

Type 3


The ABR sends type 3 summary LSAs. Type 3 LSAs advertise any networks owned by an area to the rest of the areas in the OSPF autonomous system, as shown in Figure .
The link-state ID is set to the network number; the mask is also advertised.

By default, OSPF does not automatically summarize groups of contiguous subnets or summarize a network to its classful boundary. The network operator uses configuration commands to specify how the summarization occurs. By default, a type 3 LSA is advertised into the backbone area for every subnet defined in the originating area, which can cause significant flooding problems. Consequently, you should always consider using manual route summarization at the ABR.

Summary LSAs are flooded throughout a single area only, but are regenerated by ABRs to flood into other areas.

Note By default, summary LSAs do not contain summarized routes.

Type 4

A type 4 summary LSA is generated by an ABR only when an ASBR exists within an area. A type 4 LSA identifies the ASBR and provides a route to it. The link-state ID is set to the ASBR router ID. All traffic destined to an external autonomous system requires routing table knowledge of the ASBR that originated the external routes.

In Figure , the ASBR sends a type 1 router LSA with an external bit (e bit) that is set to identify itself as an ASBR. When the ABR, which is identified with a border bit (b bit) in the router LSA, receives the type 1 LSA, it builds a type 4 LSA and floods it to the backbone (area 0). Subsequent ABRs regenerate a type 4 LSA to flood into their areas.

Type 5

Type 5 external LSAs describe routes to networks outside the OSPF autonomous system. Type 5 LSAs are originated by the ASBR and are flooded to the entire autonomous system.

The link-state ID is the external network number. Because of the flooding scope, and depending on the number of external networks, the default lack of route summarization can be a major issue with external LSAs. Therefore, you should summarize blocks of external network numbers at the ASBR to reduce flooding problems.

Type 6

Type 6 LSAs are specialized LSAs that are used in multicast OSPF applications.

Type 7

Type 7 is an LSA type that is used in not-so-stubby areas (NSSAs). They are originated by ASBRs within NSSAs and are flooded only within the NSSA in which they originated.

Type 8

Type 8 is a specialized LSA that is used in internetworking OSPF and Border Gateway Protocol (BGP).

Types 9, 10, and 11

The opaque LSAs, types 9, 10, and 11, are designated for future upgrades to OSPF for application-specific purposes. For example, Cisco Systems uses opaque LSAs for Multiprotocol Label Switching (MPLS) with OSPF. Opaque LSAs are distributed using standard LSDB flooding mechanisms. Each type has a different flooding scope.

Notes

  • loopback interfaces advitces as /32 unless ip ospf network point-to-point command is run on the Interface. 
 

Cisco launches first apprenticeship Cisco training programme for companies


Cisco has created its first apprenticeship programme, delivered in partnership with QA Apprenticeships. The programme aims to "develop a qualified, motivated workforce of Cisco practitioners around the UK", said Cisco.

Cisco added: "The move will give new apprentices the skills to manage and optimise Cisco network systems, handing IT employers a new source of talent to deliver commercial projects and expand their business."

The programme will run at both advanced and higher levels, with the first Cisco apprenticeship programmes commencing this autumn in the south east of England, with applications taken throughout this summer.

QA Apprenticeships, which will provide the training for the new programme, and Cisco recently celebrated winning the Apprenticeship Programme of the Year award from the Learning & Performance Institute for a second year running.

The award was won for creating and growing a bespoke apprenticeship programme for Cisco itself, which has brought over 20 apprentices into the networking and telecoms kit provider to date.

Ian Foddering, chief technology officer at Cisco UK and Ireland, said: “We have been aware for some time about the increasing demand from our partners and customers for apprentices with a strong Cisco knowledge. We are naturally delighted to be able to launch this programme, delivered by QA Apprenticeships, that will develop talent as we have experienced."

The new programme will offer CCNA (Cisco Certified Network Associate) and CCNP (Cisco Certified Network Professional) qualifications to apprenticeships who take part. These qualifications can also be achieved from other training providers.

Ben Pike, director of QA Apprenticeships, said: “We have worked closely with Cisco to develop their in-house apprenticeship scheme. That they have chosen us as delivery partners for their accredited industry programme cements that partnership."

 

My Blog List

Networking Domain Jobs